Citrix: Eine Verbindung mit dem Server mit Citrix Presentation Server ist nicht möglich. Fehler im Protokolltreiber

Problem: Nach einem Neustart des Citrix Presentation Servers 4.5 kann es sein das der Server keine Applikationen mehr starten kann. Die Fehlermeldung lautet:

Eine Verbindung mit dem Server mit Citrix Presentation Server ist nicht möglich. Fehler im Protokolltreiber

Beim Versuch den ICA Port per Telnet zu prüfen (telnet serverip 1494) bekommt man keine Antwort.
Lösung: In der Citrix Access Management Console wird bei den aktiven Sessions auf dem Server kein Eintrag für ICA-tcp vom Typ ICA angezeigt. Sollte das der Fall sein muss man den die ICA Connection deaktivieren und wieder aktivieren. Falls das nichts bringt die Verbindung komplett neu erstellen. Um die Verbindung zu deaktivieren öffnet man tscc.msc. Unter dem Eintrag Verbindungen kann man einen ICA-tcp udn einen RDP-Tcp Eintrag finden. Mit der Rechten Maustaste auf den ICA-tcp klicken und unter Alle Aufgaben Verbindung deaktivieren auswählen. Anschliessend auf demselben Weg die Verbindung wieder aktivieren. Dadurch wird die ICA Verbindung wieder aktiviert und der Server funktioniert wieder wie gehabt. Falls dieser Schritt das Problem nicht löst, gibt es von CItrix eine Lösung wie man die ICA-tcp Verbindung wieder neu erstellt.

Outlook can’t open / save attachments to disk

Situation: Citrix XenApp 6.5 on 2008 R2 Standard, Outlook 2010, user can’t open / save any attachments from outlook.
Solution: On the Terminal Server, go to the following Directory:

C:\Users\%USER_NAME%\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5

In this folder you’ll find various sub directories. Delete all of them and restart Outlook. You should be able to open / save files again.
I had this problem on two different infrastructures with two different users and it worked on both of them.

Mac OSX 10.7 Lion 100% CPU load after update from Snow Leopard 10.6.8

After installing OSX 10.7 Lion your CPU might go to 100% and not going down. As a result the fan is turning to a maximum speed.

There are two possibilities what’s happening.

1. Lion is indexing all your files. This might take some time. While indexing your CPU will be used to 100%. This is normal and no need to worry. You can see if your System is indexing if you check the spotlight icon in the top right corner. If the magnifier has a small dot in the center your system is indexing.

2. If there is no indexing in progress go to activity monitor and see what process is causing the problem. One of the process can be AGAdminService running as root. This process can be part of Citrix Online Plugin. If you have Citrix Plugin installed you can try to uninstall it. If it’s not working and the process still on 100% load, you have to execute the following command in a terminal session.

sudo launchctl unload -w /Library/LaunchDaemons/com.citrix.agadminservice.plist

You’ll have to enter your root password. If you execute the command the Service should disappear and shouldn’t appear at the next logon.

Thanks for this solution to mahbool in the following thread in the Apple support forums.
Link to Apple Discussions

Explorer.exe closed on Citrix session just after loading

Situation: New Installation of XenApp 6.0 on Windows 2008 Server r2
Plan: Setup a new Citrix XenApp 6.0 server and publish some applications. One of those applications would be Explorer.
Problem: If you publish explorer.exe on XenApp 6.0 it would open on the client but closes within split seconds after starting. There is no entry in the eventlog.
Solution: There is a registry key that will delay the startup of the application. This can solve the problem. It worked for my environment. There is no reboot required. Just open registry editor and go to the following path.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Citrix\wfshell\TWI

There you’ll have to add the following DWORD32 Key.
LogoffCheckerStartupDelayInSeconds
Set the value to “10” decimal.

After that you will have to logoff the client and logon again. After logon you should be able to open the published explorer.
Source: The original thread can be found here

Citrix Webinterface 5.1 Connection Timed Out

Problem: Citrix meldet offene Sessions auf dem Webinterface nach einer gewissen Zeit ab. Dadurch muss sich der User jeweils neu am Webinterface authentifizieren.

Ursache: Auf dem Webinterface ist ein Timeout gesetzt welches per Default auf 20 Minuten steht. Dadurch muss sich der User alle 20 Minuten neu anmelden.

Lösung: Auf dem Webinterface müssen die Session Preferences editiert werden. In den Preferences gibt es unter General einen Punkt Web Sessions. Dort findet man dann auch den Wert von 20 Minuten. Wird dieser Wert nun angepasst, so fliegt der User nicht mehr aus dem Webinterface bis der Counter abgelaufen ist. Setzt man den Wert auf einen Tag, so kann ein User einen ganzen Tag eingeloggt bleiben Ohne das er sich neu anmelden muss.
Screenshot der Einstellung:
timeout
Link zur Anleitung für Webinterface 3.0-4.5 sowie 5.1: Citrix KB Artikel

Citrix: WFCRUN32 – Failed to Setup Event Logging

Nach jedem Start eines PC’s mit dem 11er Client von Citrix erscheint folgende Fehlermeldung.

WFCRUN32 – Failed to Setup Event Logging

Der Fehler lässt sich auch mit einer Neuinstallation nicht beheben. Die Ursache liegt bei einer Datei die beim Update auf eine neue Version nicht aktualisiert wird. Diese Datei liegt im Profil eines jeden Users. Wird die Datei umbenannt, so erstellt der Citrix Client diese beim nächsten Restart neu. Der Fehler sollte dann direkt verschwinden. Die Datei welche man umbenennen muss ist befindet sich im Profil des Users unter folgendem Pfad

C:\Dokumente und Einstellungen\username\Anwendungsdaten\ICAClient

Um das Problem zu lösen muss die Datei APPSRV.ini umbenannt werden. Der ICA Client erstellt die Datei anschliessend wieder neu. Der Fehler sollte anschliessend verschwunden sein.

Citrix Error: Requested variable ServerURLModifiable contains the invalid bool value “”

Die Fehlermeldung Requested variable ServerURLModifiable contains the invalid bool value “” hat mich heute Morgen begrüsst. Seit einigen Tagen lassen sich aufgrund diese Fehlermeldung keine Applikationen mehr starten. Der XenApp Agent kann keine Verbindung mehr öffnen und wird mit diesem Fehler beendet. Woher der Fehler kommt kann ich nicht sagen.
Ein Update oder eine Reinstallation des Clients brachte nicht den gewünschten Erfolg. Das Problem scheint jedoch bei einigen Usern vorzukommen und so findet man in den Citrix Foren diesen Thread Die Lösung des Problems ist in Post Nummer 8 beschrieben.

Um das Problem zu beheben, muss folgender Registry Schlüssel gelöscht werden.

HKEY_CURRENT_USER\Software\Citrix\PNAgent

Ist dieser Eintrag nicht mehr vorhanden, so startet der Client wieder problemlos und ohne Fehlermeldung.

Achtung: Unsachgemässer Umgang mit dem Registry Editor kann Ihr System beschädigegen.

Citrix Dual Screen Resolution Problem

Hatte heute bei einem Presentation Server 4.0 ein Problem mit der Auflösung bei der Verwendung von unterschiedlichen Screens. Auf Farm Level muss eine Cache Size für die Grafiken in der ICA Session definiert werden. Ist dieser Cache zu klein, kommt es zu einem Anzeigefehler beim maximieren der Applikation. Diese füllt dann nicht den ganzen Screen sondern deckt nur einen Teil des erweiterten Windows Desktops sowie einen Teil des 1. Bildschirms ab. Damit ist nicht zu arbeiten.

Setzt man nun aber den entsprechenden Wert für den Grafikcache etwas hoch, lässt sich dieses Problem einfach und mit wenigen klicks beheben. Auf der Citrix Website gibt es eine Liste mit empfohlenen Cache Werten für die Unterschiedlichen Auflösungen und die entsprechende Farbtiefe.

Citrix KB Artikel: Hier

Wird der Wert angepasst, muss die Session neu afgebaut werden damit die Änderungen in Kraft treten.

icacache

Diese Einstellung gibt es sowohl für PS 4.0, 4.5 und XenApp 5.0